一个网站
你懂的

自用SSR一键脚本分享

本文由@91yun发布

本脚本来源于teddysun的一键脚本:https://shadowsocks.be/9.html

感谢teddysun大神的一键脚本

几个默认配置:

  1. 默认加密为:chacha20
  2. 默认协议为:auth_sha1_v2
  3. 默认混淆为: tls1.2_ticket_auth

有问题欢迎大家及时反馈.(91yun的官方TG群:https://telegram.me/im91yun

一键脚本的安装

本脚本安装完成后,已将 ShadowsocksR 自动加入开机自启动。

卸载方法:

使用 root 用户登录,运行以下命令:

升级方法:

使用命令:

启动:/etc/init.d/shadowsocks start
停止:/etc/init.d/shadowsocks stop
重启:/etc/init.d/shadowsocks restart
状态:/etc/init.d/shadowsocks status

配置文件路径:/etc/shadowsocks.json
日志文件路径:/var/log/shadowsocks.log
安装路径:/usr/local/shadowsocks/shadowsoks

多用户配置

如果要多个用户一起使用的话,请写入以下配置(vi /etc/shadowsocks.json):

多用户的核心是这个配置,把这个配置替代掉/etc/shadowsocks.json的相关密码的配置就行了:

“port_password”:{

“80”:”password1″,

“443”:”password2″

},

完整的多用户配置:

如果你想修改配置文件,请参考:
https://github.com/breakwa11/shadowsocks-rss/wiki/Server-Setup

打赏
未经允许不得转载:91云(91yun.org) » 自用SSR一键脚本分享

留言 183

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  1. #101

    可以不设置多用户,直接共享三个人用?

    ssr18小时前回复
    • 你把端口密码给别人不就行了

      Michael17小时前回复
  2. #100

    新版本的SSR,OTA(verify_sha1)支持,移除auth_sha1以及auth_sha1_v2 了,希望91大哥能跟进哈!!非常方便的脚本,谢谢你。

    卢松松3天前回复
  3. #99

    怎么修改ss密码?

    ss2周前 (02-05)回复
    • 修改/etc/shadowsocks.json然后重启服务。

      Michael2周前 (02-05)回复
  4. #98

    checking whether to enable maintainer-specific portions of Makefiles… no
    checking for style of include used by make… GNU
    checking for gcc… no
    checking for cc… no
    checking for cl.exe… no
    configure: error: in /root/libsodium-1.0.10':
    configure: error: no acceptable C compiler found in $PATH
    See
    config.log’ for more details
    shadowsocksR.sh: line 247: git: command not found
    Shadowsocks install failed!

    shuo3周前 (02-01)回复
  5. #97

    debian安装chacha20时出现如下错误
    安装chacha20时出错。。 libtool: warning: ‘-version-info/-version-number’ is ignored for convenience libraries
    没看懂,说什么版本问题。。请帮助

    大海3周前 (01-31)回复
    • libtool没装吧

      Michael3周前 (01-31)回复
  6. #96

    ./shadowsocksR.sh uninstall 这命令不管用,?debian7 64下
    bash: ./shadowsocksR.sh: Permission denied
    用的Root

    禅猫3周前 (01-31)回复
    • chomd +x (脚本名)

      Michael3周前 (01-31)回复
  7. #95

    卸载提示:
    -bash: ./shadowsocksR.sh: Permission denied
    这是什么原因?

    2ryan1个月前 (01-18)回复
    • chmod +x shadowsocksR.sh

      Michael1个月前 (01-18)回复
      • 谢谢,解决了~!

        2ryan1个月前 (01-18)回复
  8. #94

    如何查看多用户各个端口流量

    stef1个月前 (01-12)回复
  9. #93

    –2017-01-11 23:14:36– (try: 6) https://github.com/jedisct1/libsodium/releases/download/1.0.10/libsodium-1.0.10.tar.gz
    Connecting to github.com|192.30.253.113|:443…

    错误提示1个月前 (01-11)回复
    • 那你是连不上github我也没办法

      91yun1个月前 (01-11)回复
  10. #92

    多用户确实没法用了。另外,感觉没有必要去特意兼容SS去使用这个协议哦

    月光博客1个月前 (01-10)回复
    • 新版本就是特意不兼容SS

      Michael1个月前 (01-10)回复
  11. #91

    按照步骤改成多用户后,多用户还是无法使用。

    夕月1个月前 (01-09)回复
  12. #90

    您好,问个问题吧,2017-1-8 22:46:47刚刚服务器端的SSR不能用了,重启会报错,重新安装以后又能用。
    我的Vultr和Rectified都出现了这个问题。请问是不是auth_aes128_md5这个协议里UTC时间的问题?

    小红足疗2个月前 (01-08)回复
    • aes128不涉及到时间问题。

      91yun2个月前 (01-09)回复
      • 很像能用回去aes128啊 現在用sha1 v2速度和响应实在是差太远了
        真的无办法了吗

        屋仔1个月前 (01-10)回复
        • 自己可以找老版本代码部署。我们不制作了。

          Michael1个月前 (01-10)回复
  13. #89

    怎樣才可以用回去以前的那个版本啊?
    现在这个只能用verify_sha1
    速度真的不是一般的慢啊 差很远。。。
    希望能用回去以前那个版本 那两个最新的协议都速度很快和响应快很多 谢谢你

    屋仔2个月前 (01-04)回复
    • 无法提供。

      Michael2个月前 (01-04)回复
      • 请问为什么修改配置文件的时候,不能删除命令,按i会直接输入到里面?

        ljm1个月前 (01-13)回复
        • 用vim编辑器吧,这些学学linux你就知道。。

          Michael1个月前 (01-13)回复
        • 试试ctrl+backspace

          Hadsital2周前 (02-06)回复
  14. #88

    新版本的多用户感觉有问题呀

    小强2个月前 (01-03)回复
    • 我也觉得多用户配置的时候有问题,不知道要怎么解决

      hang_zhang1个月前 (01-09)回复
  15. #87

    对了,之前说的PC能连实际上是我的错觉,我谷歌浏览器有快速安全通道。所以客户端的连接统计一直是空的,shadowsocks.log里也没有日志。。

    jiufen2个月前 (01-03)回复
  16. #86

    额,好吧,我把锐速卸载重装以后莫名其妙的就好了。。

    jiufen2个月前 (01-03)回复
  17. #85

    楼主你好,非常感谢你的博文和脚本,新手福音啊。我用的是vultr的VPS,洛杉矶节点。安装的是centos 6 x64,装好后参照你的《锐速破解版linux一键自动安装包(8月7日更新)》和《教程:CentOS更换内核,提供锐速可用的内核下载》把内核更换成了2.6.32-504.3.3.el6.x86_64,然后安装了锐速破解版一键包。然后使用了SSR一键脚本,加密、协议、混肴都是默认值。PC的客户端用的是ShadowsocksR-4.0.3-win,效果挺好。手机是oppo r9m,用的shadowsocksR-v3.3.2,配置直接扫码PC的,点击小飞机后能连,但是访问什么网站都打不开。/var/log/shadowsocks.log里只有服务启动的日志,看不到任何连接日志,PC的都没有。请问这种情况该怎么处理?

    jiufen2个月前 (01-03)回复
  18. #84

    auth_sha1系列的恢复compatible支持了

    Dwwwwww2个月前 (01-02)回复
  19. #83

    免流目前普遍都挂了,楼主这次更新是修复好了免流吗?

    newtzer2个月前 (01-01)回复
    • 从不关注免流问题。

      91yun2个月前 (01-02)回复
  20. #82

    吓坏我了 以后我都不敢随便用ssh随意更新了。这次除了更新手动需要切换协议以外,我发现连默认的卸载命令都没办法执行了。

    Jackie2个月前 (01-01)回复
  21. #81

    新版的多用户如何配置

    ljm2个月前 (12-31)回复
    • 跟原来的一样,只是协议什么的注意改。

      Jackie2个月前 (01-01)回复
  22. #80

    确实,我的重装系统后安装28日的版本也用不了,期待站长更新哇。加油

    卢松松2个月前 (12-30)回复
  23. #79

    新的似乎无法使用

    光锥2个月前 (12-30)回复
    • 今天会重新发个包

      91yun2个月前 (12-30)回复
      • 嗯,我说怎么都没有网,然后呢提示插件都不支持……

        光锥2个月前 (12-30)回复
    • 同等最新版。

      卢松松2个月前 (12-30)回复
  24. #78

    博主,今天我用
    cd /usr/local/shadowsocks/shadowsocks
    git pull
    更新后连不上了求救

    mizu2个月前 (12-30)回复
    • 新的服务器版本已经不支持原版ss客户端。请用ssr的客户端

      91yun2个月前 (12-30)回复
      • 连compartable都不行了吗

        光锥2个月前 (12-30)回复
        • 新版SSR必须使用SSR客户端

          Michael2个月前 (12-30)回复
  25. #77

    有没有净ss的一键包?

    2ryan2个月前 (12-13)回复
  26. #76

    博主,你这个增加时区版本貌似有问题(也可能是我自己的问题),我拿2台vps安装过都无法正常使用(客户端报错无法连接到升级服务器)服务端报错“”Enjoy it!

    Error resolving 1.cn.pool.ntp.org: No address associated with hostname (-5)
    11 Dec 15:44:36 ntpdate[27555]: Can’t find host 1.cn.pool.ntp.org: No address associated with hostname (-5)
    11 Dec 15:44:36 ntpdate[27555]: no servers can be used, exiting

    我不知道是我自己vps主机名的问题?还是其他问题?同样vps用泰迪熊的没时区版本就ok,望博主指点一二

    z2个月前 (12-11)回复
  27. #75

    (try:13) https://raw.githubusercontent.com/91yun/shadowsocks_install/master/shadowsocksR.sh
    Connecting to raw.githubusercontent.com|151.101.44.133|:443… failed: Connection timed out.
    Retrying.

    fire3个月前 (11-30)回复
  28. #74

    站长你好,请问这个一键包安装的ssr版本号是多少

    KongBai3个月前 (11-30)回复
    • 是直接github上的最新版的。我只是代码安装而已,用的都是直接clone最新版

      91yun3个月前 (11-30)回复
  29. #73

    多端口设置了连接不上了,默认的就能链接上,这是怎么回事?

    drd3个月前 (11-24)回复
  30. #72

    你好,请问win客户端在哪里下?

    91fans3个月前 (11-20)回复
  31. #71

    最近的一周装了,但是怎么不能连接了啊!!!!以前可以,同样的服务器,是不是哪里修改了啊?

    DAY3个月前 (11-10)回复
    • 我也是

      凌越3个月前 (11-12)回复
    • 遇到同样的问题了,求解

      loren3个月前 (11-12)回复
  32. #70

    请问楼主,这个脚本亚马逊的EC2能不能用?

    小小白4个月前 (10-29)回复
  33. #69

    安装完成一键脚本之后可以连上搭建好的SSR,但是没有任何上传下载数据
    日志查询出来只有以下这些信息
    2016-10-26 09:55:27 INFO asyncdns.py:324 dns server: [(‘8.8.8.8’, 53), (‘74.82.42.42’, 53), (‘4.2.2.1’, 53), (‘8.8.4.4’, 53)]
    2016-10-26 09:55:27 INFO server.py:100 server start with protocol[auth_sha1_compatible] password [xxxxxx] method [chacha20] obfs [http_simple_compatible] obfs_param []
    2016-10-26 09:55:27 INFO server.py:116 starting server at [::]:139
    2016-10-26 09:55:27 INFO server.py:136 starting server at 0.0.0.0:139

    请问问题出在哪里呢?

    chris4个月前 (10-26)回复
  34. #68

    挂了?

    bigback4个月前 (10-23)回复
  35. #67

    安装过程中有4次这样的警告
    libtool: warning: ‘-version-info/-version-number’ is ignored for convenience
    但是目前用起来没什么问题,有什么地方需要调整么?

    zhengxinhn4个月前 (10-22)回复
  36. #66

    /usr/local/shadowsocks/shadowsocks/../shadowsocks/shell.py:177: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
    e.message)
    ERROR: found an error in config.json: Invalid control character at: line 7 column 19 (char 153)
    ShadowsocksR start failed

    hhhhh4个月前 (10-19)回复
  37. #65

    hostus 是不是屏蔽了SSR安装包的使用 总是出现 解析失败

    semgooder4个月前 (10-14)回复
  38. #64

    安装的时候提示这个,centos7 64,可以安装完成,链接不上。

    CC crypto_stream/salsa208/ref/libsodium_la-xor_salsa208.lo
    CC crypto_aead/aes256gcm/aesni/libaesni_la-aead_aes256gcm_aesni.lo
    CCLD libaesni.la
    libtool: warning: ‘-version-info/-version-number’ is ignored for convenience libraries
    CC crypto_pwhash/scryptsalsa208sha256/sse/libsse2_la-pwhash_scryptsalsa208sha256_sse.lo
    CC crypto_onetimeauth/poly1305/sse2/libsse2_la-poly1305_sse2.lo
    CCLD libsse2.la
    libtool: warning: ‘-version-info/-version-number’ is ignored for convenience libraries
    CC crypto_generichash/blake2/ref/libssse3_la-blake2b-compress-ssse3.lo
    CC crypto_pwhash/argon2/libssse3_la-argon2-fill-block-ssse3.lo
    CC crypto_stream/chacha20/vec/libssse3_la-stream_chacha20_vec.lo
    CCLD libssse3.la
    libtool: warning: ‘-version-info/-version-number’ is ignored for convenience libraries
    CC crypto_generichash/blake2/ref/libsse41_la-blake2b-compress-sse41.lo
    CCLD libsse41.la
    libtool: warning: ‘-version-info/-version-number’ is ignored for convenience libraries
    CC crypto_generichash/blake2/ref/libavx2_la-blake2b-compress-avx2.lo
    CCLD libavx2.la
    libtool: warning: ‘-version-info/-version-number’ is ignored for convenience libraries
    CCLD libsodium.la
    make[3]: Leaving directory /root/libsodium-1.0.10/src/libsodium'
    make[2]: Leaving directory
    /root/libsodium-1.0.10/src/libsodium’

    新人王4个月前 (10-12)回复
  39. #63

    cd /usr/local/shadowsocks/shadowsocks 无法升级了?

    风云4个月前 (10-11)回复
  40. #62

    站长你好!首先感谢提供脚本!我发现你这个一键脚本安装完之后本来端口是设置成1081的,而最后安装成功却是显示1080的。查看了一下代码,应该是代码里面有误了。

    nuoran5个月前 (10-09)回复
  41. #61

    博主,我安装了这个ssr,现在想卸载,卸载提示权限不足,怎么解决?
    [[email protected] ~]# ./shadowsocksR.sh uninstall
    -bash: ./shadowsocksR.sh: Permission denied
    [[email protected] ~]#

    玖月5个月前 (10-08)回复
    • chmod 777 shadowsocksR.sh

      exitwin984个月前 (10-29)回复
  42. #60

    alpharacks的vps出错一直retrying

    xiaoxiao5个月前 (10-08)回复
  43. #59

    –2016-10-07 13:06:11– https://github.com/jedisct1/libsodium/releases/download/1.0.10/libsodium-1.0.10.tar.gz
    Resolving github.com (github.com)… 192.30.253.112
    Connecting to github.com (github.com)|192.30.253.112|:443… failed: Connection timed out.
    Retrying.

    –2016-10-07 13:07:15– (try: 2) https://github.com/jedisct1/libsodium/releases/download/1.0.10/libsodium-1.0.10.tar.gz
    Connecting to github.com (github.com)|192.30.253.112|:443… failed: Connection timed out.
    Retrying.

    –2016-10-07 13:08:20– (try: 3) https://github.com/jedisct1/libsodium/releases/download/1.0.10/libsodium-1.0.10.tar.gz
    Connecting to github.com (github.com)|192.30.253.112|:443… failed: Connection timed out.
    Retrying.

    –2016-10-07 13:09:26– (try: 4) https://github.com/jedisct1/libsodium/releases/download/1.0.10/libsodium-1.0.10.tar.gz
    Connecting to github.com (github.com)|192.30.253.112|:443…

    xiaoxiao5个月前 (10-08)回复
  44. #58

    追问一下,我是想用ss玩游戏,请问需要做其他 的什么设置吗?

    大片儿刀5个月前 (10-02)回复
  45. #57

    站长您好,之前一直是 用淘宝买的vps,一键ss之后就可以正常使用,这几天更换了kvmla的vps 使用这个脚本之后无法正常启用,访问ytb显示500错误,但是从网上找了另一个脚本,就可以正常使用。一直找不到原因,请问这个新的kvm的vps 有什么办法使用您的脚本吗?

    大片儿刀5个月前 (10-02)回复
    • 你要看下日志是什么错误

      91yun5个月前 (10-06)回复
  46. #56

    问一下,用挂SSR玩游戏总是超时怎么办120分钟超时一次

    Dream知心5个月前 (09-28)回复
  47. #55

    请问ShadowsocksR电脑端最新版ShadowsocksR-dotnet2.0和ShadowsocksR-dotnet4.0有什么区别?为什么每个版本都有2.0和4.0?

    Chilsion5个月前 (09-27)回复
    • 对应不同的net框架吧

      91yun5个月前 (09-28)回复
      • 但是2.0和4.0在电脑上都能用,也看不出来哪里有区别,作者也没有说明。。。。

        Chilsion5个月前 (09-28)回复
  48. #54

    ntpdate[1432]: Can’t adjust the time of day: Operation not permitted
    提示无法调整时间,没有操作权限

    可以这个VPS不允许调整时间,我们可以使用如下方法来调整:

    cp /usr/share/zoneinfo/Asia/Shanghai /etc/localtime

    柒月5个月前 (09-27)回复
  49. #53

    我用的ubuntu 14.04 ,启动ssr服务后,无法连接(已关闭防火墙),使用netstat查看相关服务,ssr服务前缀都是tcp6,没有tcp连接,这该怎么处理啊???

    nnn5个月前 (09-26)回复
  50. #52

    连接挂了

    Dream知心5个月前 (09-23)回复
  51. #51

    表哥,我昨天手贱在原本的vpen vpn免流上面装了个这个,然后ssr可以用,vpn免流连接上没有网,怎么办啊!!!!江湖救急 啊!!!

    红酒半杯5个月前 (09-22)回复
    • 没用过openvpn不知道什么问题

      91yun5个月前 (09-23)回复
      • 有没有可能是端口或者防火墙什么的问题,能连接上就是没有网络

        红酒半杯5个月前 (09-24)回复
  52. #50

    用这个搭建的能开UDP转发吗 有知道的大兄弟吗

    mlwithss5个月前 (09-21)回复
  53. #49

    很后悔今天手贱更新ssr….更新后延迟变高了,动不动就超时。请问有办法安装旧版本吗?

    Andy5个月前 (09-20)回复
    • 服务端还是客户端?

      Jack5个月前 (09-20)回复
      • 服务端

        Andy5个月前 (09-20)回复
  54. #48

    楼主,Krypt的洛杉矶机子安装ssR不成功,操作系统是debian GNU 64位,然后安装时出现了这样的问题,咋办?求教一下
    checking build system type… x86_64-unknown-linux-gnu
    checking host system type… x86_64-unknown-linux-gnu
    checking for a BSD-compatible install… /usr/bin/install -c
    checking whether build environment is sane… yes
    checking for a thread-safe mkdir -p… /bin/mkdir -p
    checking for gawk… no
    checking for mawk… mawk
    checking whether make sets $(MAKE)… no
    checking whether make supports nested variables… no
    checking whether UID ‘0’ is supported by ustar format… yes
    checking whether GID ‘0’ is supported by ustar format… yes
    checking how to create a ustar tar archive… gnutar
    checking whether make supports nested variables… (cached) no
    checking whether to enable maintainer-specific portions of Makefiles… no
    checking for style of include used by make… none
    checking for gcc… no
    checking for cc… no
    checking for cl.exe… no
    configure: error: in /root/libsodium-1.0.10':
    configure: error: no acceptable C compiler found in $PATH
    See
    config.log’ for more details
    shadowsocksR.sh: line 242: git: command not found
    Shadowsocks install failed!
    安装失败。。。。不是太懂。。。。诚心求教。。。。。

    PokoWee5个月前 (09-19)回复
  55. #47

    开多端口要不要防火墙放行新开的端口?

    mlwithss5个月前 (09-18)回复
  56. #46

    请问博主,我装好了,现在想改ssr端口的话,用什么命令?谢谢

    sonny5个月前 (09-15)回复
  57. #45

    centos6.5也不能卸载 有一样的兄弟吗

    mlwithss5个月前 (09-14)回复
    • 把 shadowsocksR.sh 文件权限改成 777 再键入 ./shadowsocksR.sh uninstall 回车,键入 Y 即可卸载

      Tiny5个月前 (09-18)回复
      • 谢谢 成了

        mlwithss5个月前 (09-18)回复
        • 怎么改啊

          jack8265个月前 (09-18)回复
      • 请问下这个权限怎么改?在哪改?真的不懂,请指教下。谢谢!

        jack8265个月前 (09-19)回复
      • 一样无法卸载 chmod +x 文件名 还是 chmod 777 文件名 怎么加权限 就不能说清楚点?? 小白试了不行

        阿里路呀4个月前 (10-13)回复
  58. #44

    centos6不能卸载

    das5个月前 (09-12)回复
  59. #43

    [[email protected] ~]# ./shadowsocksR.sh uninstall
    -bash: ./shadowsocksR.sh: Permission denied

    das5个月前 (09-12)回复
    • 把 shadowsocksR.sh 文件权限改成 777 再键入 ./shadowsocksR.sh uninstall 回车,键入 Y 即可卸载

      Tiny5个月前 (09-18)回复
  60. #42

    您好,请问这个SSR玩游戏延迟有点大,有没有办法降低呢?网上说锐速可以,但是锐速是tcp,我不知道有没有效果,谢谢。

    小冰6个月前 (09-10)回复
  61. #41

    请问博主,怎么把混淆和协议修改为tls1.2_ticket_auth和auth_sha1_v3,同时兼容原版呢?

    易水寒6个月前 (09-09)回复
    • 参考https://github.com/breakwa11/shadowsocks-rss/wiki/obfs

      91yun6个月前 (09-10)回复
      • 好的,谢谢您的回复。

        易水寒6个月前 (09-10)回复
  62. #40

    不好意思,是我自己代码没有复制完整,脚本没有问题

    starmoon6个月前 (09-02)回复
  63. #39

    脚本400错误了

    starmoon6个月前 (09-02)回复
  64. #38

    多端口保存重启后还是原来的 怎么回事

    大白6个月前 (09-02)回复
  65. #37

    怎么卸载

    奈何薄荷已凉心6个月前 (08-29)回复
  66. #36

    wget -N –no-check-certificate https://raw.githubusercontent.com/91yun/shadowsocks_install/master/shadowsocksR.sh && bash shadowsocksR.sh

    das6个月前 (08-23)回复
  67. #35

    什么人啊.破脚本还要密码。不让容旧别发文章。发了加密码。是找喷

    das6个月前 (08-23)回复
    • 我们没遇到密码,自己的原因,喷子

      justs0o6个月前 (08-23)回复
    • 傻吊,那是设置SSR的密码

      小冰6个月前 (09-10)回复
  68. #34

    去这个位置加载的时候失败了,什么原因呢,谢谢!
    Connecting to github-cloud.s3.amazonaws.com|54.231.81.72|:443… connected.
    HTTP request sent, awaiting response… 403 Forbidden
    2016-08-22 07:56:25 ERROR 403: Forbidden.

    Failed to download libsodium file!

    zzld6个月前 (08-22)回复
  69. #33

    去这个地方加载的时候失败了,
    github-cloud.s3.amazonaws.com|54.231.81.72|:443

    zzld6个月前 (08-22)回复
  70. #32

    2016-08-21 02:40:10 ERROR shell.py: 50 [Errno 97] Address family not supported by protoco

    为什么我手动或者一键都会出现这个错误可以麻烦您看一下吗 谢谢了。

    sshrssrhshs6个月前 (08-21)回复
  71. #31

    IPv6 not support
    INFO: loading config from /root/shadowsocks/shadowsocks/../shadowsocks/../config.json
    2016-08-21 02:40:10 INFO util.py:85 loading libcrypto from libcrypto.so.10
    2016-08-21 02:40:10 INFO asyncdns.py:324 dns server: [(‘8.8.8.8’, 53), (‘8.8.4.4’, 53)]
    2016-08-21 02:40:10 INFO server.py:98 server start with protocol[auth_sha1_compatible] password [password] method [aes-256-cfb] obfs [http_simple] obfs_param []
    2016-08-21 02:40:10 INFO server.py:114 starting server at [::]:8989
    2016-08-21 02:40:10 ERROR shell.py:50 [Errno 97] Address family not supported by protocol
    2016-08-21 02:40:10 INFO server.py:134 starting server at 0.0.0.0:8989

    为什么我手动或者一键都会出现这个错误可以麻烦您看一下吗 谢谢了。

    sshrssrhshs6个月前 (08-21)回复
    • 你可以去隔壁ssr作者那问。。

      91yun6个月前 (08-21)回复
  72. #30

    改成多用户就无法启动服务了,折腾了一下午了

    Lucky6个月前 (08-17)回复
    • 多用户请自行按官方wiki安装哦。我这只解决单用户的一键安装

      91yun6个月前 (08-17)回复
  73. #29

    请问 SSR 后台有没有设置一个端口超过设备数量就限速的设置呢?

    terrytan6个月前 (08-17)回复
    • 没有

      91yun6个月前 (08-17)回复
  74. #28

    这个包含了 chacha20所需插件吗/?

    terrytan6个月前 (08-17)回复
    • 91yun6个月前 (08-17)回复
  75. #27

    不支持UDP转发呀站长,不管是用软件sockscap64还是用路由器都无法UDP转发。。。这样就没法玩外服游戏了。

    ss6个月前 (08-16)回复
    • ssr默认支持udp转发的哦,检查你的防火墙是否开启

      91yun6个月前 (08-16)回复
      • 我的vps 路由 以及电脑的防火墙,本就是关闭状态的。之前用lebv版的ss可以转发UDP 谢谢站长

        ss6个月前 (08-17)回复
        • ssr的udp转发,设置里应该填什么呢

          ljm14476698732个月前 (12-10)回复
  76. #26

    SS for Android 最新更新在PLAY市场,新的客户端支持KCP协议。请问站长,这个KCP协议如何使用呢?听说很神话。如果能结合出个最新的SSR一键包就好了。

    Jackie6个月前 (08-12)回复
    • 同求

      miss6个月前 (08-14)回复
  77. #25

    我只有百度有网,其他没有网怎么回事,地区问题吗,别人有网

    稳心7个月前 (08-10)回复
  78. #24

    2016-08-07 13:22:33 ERROR tcprelay.py:841 [Errno 104] Connection reset by peer
    2016-08-07 13:22:33 ERROR tcprelay.py:842 exception from ::ffff:124.226.46.33:6385
    2016-08-07 13:22:33 ERROR tcprelay.py:841 [Errno 104] Connection reset by peer
    2016-08-07 13:22:33 ERROR tcprelay.py:842 exception from ::ffff:124.226.46.33:6394
    2016-08-07 13:25:01 ERROR tcprelay.py:841 [Errno 104] Connection reset by peer
    2016-08-07 13:25:01 ERROR tcprelay.py:842 exception from ::ffff:124.226.46.33:8046
    2016-08-07 13:25:01 ERROR tcprelay.py:841 [Errno 104] Connection reset by peer
    2016-08-07 13:25:01 ERROR tcprelay.py:842 exception from ::ffff:124.226.46.33:8047
    站长用了你这个一键包安装的时候一切都好,可是现在就是用不了!
    2016-08-07 13:25:01 ERROR tcprelay.py:841 [Errno 104] Connection reset by peer
    2016-08-07 13:25:01 ERROR tcprelay.py:842 exception from ::ffff:124.226.46.33:7235

    望站长帮忙7个月前 (08-07)回复
    • 你要看服务器端日志后客户端日志,看看是什么情况。连不上一般是服务没启动或者iptables防火墙端口没开。连上用不了,可能是加密方式错误,要看具体日志

      91yun7个月前 (08-07)回复
      • 麻烦站长了,这个是客户端的日志
        [2016-08-07 12:35:07] ShadowsocksR started
        [2016-08-07 12:35:17] [Warn]Proxy server [(127.0.0.1)] connection refused
        [2016-08-07 12:35:19] [Warn]Proxy server [(127.0.0.1)] connection refused
        [2016-08-07 12:35:20] [Warn]Proxy server [(127.0.0.1)] connection refused
        [2016-08-07 12:35:21] [Warn]Proxy server [(127.0.0.1)] connection refused
        [2016-08-07 12:35:22] [Warn]Proxy server [(127.0.0.1)] connection refused
        [2016-08-07 12:35:23] [Warn]Proxy server [(127.0.0.1)] connection refused
        [2016-08-07 12:35:24] [Warn]Proxy server [(127.0.0.1)] connection refused
        [2016-08-07 12:35:25] [Warn]Proxy server [(127.0.0.1)] connection refused
        [2016-08-07 12:35:25] [Error]connect to update server error
        [2016-08-07 13:16:13] ShadowsocksR started
        [2016-08-07 13:16:24] [Error]connect to update server error

        望站长帮忙7个月前 (08-07)回复
        • 端口或者服务没启动。连接被拒绝了

          91yun7个月前 (08-07)回复
          • 重启一下服务器

            xzzzzx5个月前 (09-23)
  79. #23

    配置了多用户后,无法启动。。
    “server”: “0.0.0.0”,
    “server_ipv6”: “::”,
    “local_address”: “127.0.0.1”,
    “local_port”: 1080,
    “password”: {
    “2333”:”8642871″,
    “2444”:”hellodabo”,
    “2555”:”nononono”
    },
    “timeout”: 120,
    “udp_timeout”: 60,
    “method”: “chacha20”,
    “protocol”: “auth_sha1_compatible”,
    “protocol_param”: “”,
    “obfs”: “http_simple_compatible”,
    “obfs_param”: “”,
    “dns_ipv6”: false,
    “redirect”: “”,
    “fast_open”: false,
    “workers”: 1

    mildnes7个月前 (08-06)回复
  80. #22

    如何修改为数据库版呢?

    mrqh7个月前 (08-05)回复
  81. #21

    你是好人,喜欢你!!!

    TTkea7个月前 (07-24)回复
  82. #20

    推荐直接更新sha1 v2+tls1.2

    neo7个月前 (07-20)回复
  83. #19

    站长,ssr总自动关闭进程的话应该用啥东西搞搞呢 ?有啥连接或者教程没thanks

    shakbari7个月前 (07-18)回复
    • 耗资源太多被杀了?

      91yun7个月前 (07-18)回复
      • 沒呀,就三四個人看看youtube 而已

        shakbari7个月前 (07-20)回复
  84. #18

    编译libsodium的时候出现libtool: warning: ‘-version-info/-version-number’ is ignored for convenience libraries

    Maskrighter7个月前 (07-15)回复
    • 不太清楚,没碰到过

      91yun7个月前 (07-15)回复
      • 要哭了

        Maskrighter7个月前 (07-15)回复
  85. #17

    为什么ssr脚本中途报libtool: warning: ‘-version-info/-version-number’ is ignored for convenience libraries
    最后报no server suitable for synchronization found 最后想要卸载却报update-rc.d: using dependency based boot sequencing
    insserv: warning: script ‘K01pureftpd’ missing LSB tags and overrides
    insserv: warning: script ‘K01httpd’ missing LSB tags and overrides
    insserv: warning: script ‘K01memcached’ missing LSB tags and overrides
    insserv: warning: script ‘memcached’ missing LSB tags and overrides
    insserv: warning: script ‘pureftpd’ missing LSB tags and overrides
    insserv: warning: script ‘httpd’ missing LSB tags and overrides

    Maskrighter7个月前 (07-15)回复
  86. #16

    一键安装完,没有安装目录,也没有安装日志。倒是配置文件还是有的。
    截取一小段安装
    ———————————————————————-
    Libraries have been installed in:
    /usr/local/lib

    If you ever happen to want to link against installed libraries
    in a given directory, LIBDIR, you must either use libtool, and
    specify the full pathname of the library, or use the ‘-LLIBDIR’
    flag during linking and do at least one of the following:
    – add LIBDIR to the ‘LD_LIBRARY_PATH’ environment variable
    during execution
    – add LIBDIR to the ‘LD_RUN_PATH’ environment variable
    during linking
    – use the ‘-Wl,-rpath -Wl,LIBDIR’ linker flag
    – have your system administrator add LIBDIR to ‘/etc/ld.so.conf’

    See any operating system documentation about shared libraries for
    more information, such as the ld(1) and ld.so(8) manual pages.
    ———————————————————————-
    make[4]: Nothing to be done for install-data-am'.
    make[4]: Leaving directory
    /root/home/libsodium-1.0.10/src/libsodium’
    make[3]: Leaving directory /root/home/libsodium-1.0.10/src/libsodium'
    make[2]: Leaving directory
    /root/home/libsodium-1.0.10/src/libsodium’
    make[2]: Entering directory /root/home/libsodium-1.0.10/src'
    make[3]: Entering directory
    /root/home/libsodium-1.0.10/src’
    make[3]: Nothing to be done for install-exec-am'.
    make[3]: Nothing to be done for
    install-data-am’.
    make[3]: Leaving directory /root/home/libsodium-1.0.10/src'
    make[2]: Leaving directory
    /root/home/libsodium-1.0.10/src’
    make[1]: Leaving directory /root/home/libsodium-1.0.10/src'
    Making install in test
    make[1]: Entering directory
    /root/home/libsodium-1.0.10/test’
    Making install in default
    make[2]: Entering directory /root/home/libsodium-1.0.10/test/default'
    make[3]: Entering directory
    /root/home/libsodium-1.0.10/test/default’
    make[3]: Nothing to be done for install-exec-am'.
    make[3]: Nothing to be done for
    install-data-am’.
    make[3]: Leaving directory /root/home/libsodium-1.0.10/test/default'
    make[2]: Leaving directory
    /root/home/libsodium-1.0.10/test/default’
    make[2]: Entering directory /root/home/libsodium-1.0.10/test'
    make[3]: Entering directory
    /root/home/libsodium-1.0.10/test’
    make[3]: Nothing to be done for install-exec-am'.
    make[3]: Nothing to be done for
    install-data-am’.
    make[3]: Leaving directory /root/home/libsodium-1.0.10/test'
    make[2]: Leaving directory
    /root/home/libsodium-1.0.10/test’
    make[1]: Leaving directory /root/home/libsodium-1.0.10/test'
    make[1]: Entering directory
    /root/home/libsodium-1.0.10′
    make[2]: Entering directory /root/home/libsodium-1.0.10'
    make[2]: Nothing to be done for
    install-exec-am’.
    /bin/mkdir -p ‘/usr/local/lib/pkgconfig’
    /usr/bin/install -c -m 644 libsodium.pc ‘/usr/local/lib/pkgconfig’
    make[2]: Leaving directory /root/home/libsodium-1.0.10'
    make[1]: Leaving directory
    /root/home/libsodium-1.0.10′
    Initialized empty Git repository in /usr/local/shadowsocks/.git/
    Shadowsocks install failed!

    Qa8个月前 (07-12)回复
  87. #15

    完全看不懂。。。。

    ss8个月前 (07-12)回复
  88. #14

    你好,请教一下这个ssr服务端在安卓手机用原版客户端能正常连接吗?我在安卓设置好加密为:chacha20后
    翻不了墙。。。。。

    Andy8个月前 (07-06)回复
    • 可以的。应该是你其他地方没设置好。检测防火墙,密码和加密方式是否填对。看下服务器端的错误日志tail /var/log/shadowsocks.log

      91yun8个月前 (07-06)回复
      • 2016-07-06 15:18:48 ERROR tcprelay.py:851 can not parse header when handling connection from ::ffff:117.136.41.79:2506
        2016-07-06 15:18:48 WARNING common.py:228 unsupported addrtype 69, maybe wrong password or encryption method
        2016-07-06 15:18:48 WARNING tcprelay.py:367 Protocol ERROR, TCP ogn data 55e6ab55d295292449b59f69efe35a11965a85df211afd583f1ab9d975fe8cec3ed5b0d10b2ab4beb34b47aba7bd25af4451b3c99bb0a85b228fb6ef3b from ::ffff:117.136.41.79:2486 via port 443
        2016-07-06 15:18:48 ERROR tcprelay.py:851 can not parse header when handling connection from ::ffff:117.136.41.79:2486
        2016-07-06 15:18:48 WARNING common.py:228 unsupported addrtype 69, maybe wrong password or encryption method
        2016-07-06 15:18:48 WARNING tcprelay.py:367 Protocol ERROR, TCP ogn data 6b4d367087ddd525491218cdd21c42ec6d0e62d4d0d826f1398fd613a40e086670e6fea14fe0f91d31b3c329349901982c0128c4eef1cbe7 from ::ffff:117.136.41.79:2507 via port 443
        2016-07-06 15:18:48 ERROR tcprelay.py:851 can not parse header when handling connection from ::ffff:117.136.41.79:2507
        2016-07-06 15:18:49 WARNING common.py:228 unsupported addrtype 69, maybe wrong password or encryption method
        2016-07-06 15:18:49 WARNING tcprelay.py:367 Protocol ERROR, TCP ogn data 9e0affca19888d6d5cba7d339081a585ba6fd8d8f70353fdbec0119e90c2d3e24863e2f98c85b815ad2810c0c49c562165bbb4231e121177f4e00476ca from ::ffff:117.136.41.79:2508 via port 443
        2016-07-06 15:18:49 ERROR tcprelay.py:851 can not parse header when handling connection from ::ffff:117.136.41.79:2508

        帮忙看看,谢谢

        Andy8个月前 (07-06)回复
        • 检查你的密码和加密方式。或者你手动把配置文件的加密方式改成rc4-md5看看

          91yun8个月前 (07-06)回复
  89. #13

    请教一下, 用了这个ssr安装包, 可是原版客户端连不上, 不能兼容么?

    marcus8个月前 (07-01)回复
    • 肯定是设置问题.

      91yun8个月前 (07-01)回复
      • 客户端设置还是服务器端?服务器端安装好以后,只改了密码和端口. 原版客户端运行以后没有报错, 但是油管什么都上不去

        marcus8个月前 (07-01)回复
        • 好吧。。请忽略这个问题,换了一个VPS以后居然好了

          marcus8个月前 (07-01)回复
  90. #12

    2016-06-28 17:50:49 INFO server.py:114 starting server at [::]:25565
    2016-06-28 17:50:49 INFO server.py:134 starting server at 0.0.0.0:25565
    2016-06-28 17:52:53 ERROR tcprelay.py:811 [Errno 110] Connection timed out
    2016-06-28 17:52:53 ERROR tcprelay.py:813 when connect to http://www.google.com:80 from ::ffff:121.8.136.223:5812
    2016-06-28 17:53:28 ERROR tcprelay.py:811 [Errno 110] Connection timed out
    2016-06-28 17:53:28 ERROR tcprelay.py:813 when connect to s.qhupdate.com:80 from ::ffff:121.8.136.223:5823
    2016-06-28 17:53:28 ERROR tcprelay.py:811 [Errno 110] Connection timed out
    2016-06-28 17:53:28 ERROR tcprelay.py:813 when connect to s.qhupdate.com:80 from ::ffff:121.8.136.223:5822
    2016-06-28 17:53:56 ERROR tcprelay.py:811 [Errno 110] Connection timed out
    2016-06-28 17:53:56 ERROR tcprelay.py:813 when connect to http://www.google.com:80 from ::ffff:121.8.136.223:6064
    2016-06-28 17:56:30 INFO asyncdns.py:324 dns server: [(‘108.61.10.10’, 53)]
    2016-06-28 17:56:30 INFO server.py:98 server start with protocol[auth_sha1_compatible] password [950812wan] method [chacha20] obfs [http_simple_compatible] obfs_param []
    2016-06-28 17:56:30 INFO server.py:114 starting server at [::]:25565
    2016-06-28 17:56:30 INFO server.py:134 starting server at 0.0.0.0:25565
    loaded collections.OrderedDict
    IPv6 support
    started
    2016-06-28 18:58:42 INFO asyncdns.py:324 dns server: [(‘108.61.10.10’, 53)]
    2016-06-28 18:58:42 INFO server.py:98 server start with protocol[auth_sha1_compatible] password [950812wan] method [chacha20] obfs [http_simple_compatible] obfs_param []
    2016-06-28 18:58:42 INFO server.py:114 starting server at [::]:25565
    2016-06-28 18:58:42 INFO server.py:134 starting server at 0.0.0.0:25565

    看了下日志 是这些 也没啥报错呀 不懂了

    Linz8个月前 (06-28)回复
    • 没连上啊。连上的日志都没有。

      91yun8个月前 (06-28)回复
      • 啊,那是啥意思。 密码和加密我都弄对了… 之前go也是 chacha20.

        Linz8个月前 (06-28)回复
  91. #11

    楼主我刚把go删了 装这个 防火墙也设置好的 连上了 但是网站什么的 都打不开。设置也没啥问题。

    Linz8个月前 (06-28)回复
    • 密码和加密问题把。你可以看下日志有什么提示

      91yun8个月前 (06-28)回复
  92. #10

    感谢91yun,

    我觉得吧,混淆改成tls1.0_session_auth比较好,亲测比http要快

    烟灰8个月前 (06-21)回复
    • tls1.0作者都不推荐了

      91yun8个月前 (06-21)回复
  93. #9

    请教下:root 用户登录运行卸载SSR命令,提示没有权限,要怎么解决?

    psy1638个月前 (06-16)回复
    • 加TG群截图看问下大家看。没碰到这个问题

      91yun8个月前 (06-16)回复
  94. #8

    请问为什么我的centos7系统openvpn和ss同时搭建了openvpn就无法登录了?一直显示waiting for proxy server 而我以前用debian7同时搭建就没出过问题 我记得好像看过一篇文章说是因为centos7的防火墙问题 一个是用了iptable 一个是ipfawall什么的 可惜那篇文章我找不到了

    maldal8个月前 (06-13)回复
    • 不知道。没怎么研究openvpn

      91yun8个月前 (06-13)回复
  95. #7

    为什么安装后没办法用

    AAA9个月前 (06-11)回复
    • 这个太笼统了。

      91yun9个月前 (06-11)回复
  96. #6

    楼主,time out 设置成120太小了,线路不好的人容易连接出问题的

    Simon9个月前 (06-06)回复
    • 我没见过线路差到了120秒的,这种情况应该换线路,因为差得不能用了(作者原话。哈哈)

      91yun9个月前 (06-06)回复
  97. #5

    谢谢楼主啊

    Joshua9个月前 (06-05)回复
  98. #4

    推荐:auth_sha1+tls1.2_ticket_auth

    hello9个月前 (06-05)回复
  99. #3

    感谢楼主,请问有安卓手机客户端推荐么?

    Kevin9个月前 (06-05)回复
    • 没有。手机只有ss客户端

      91yun9个月前 (06-05)回复
  100. #2

    特地留言感谢,感谢楼主!

    柔柔之握9个月前 (06-05)回复
  101. #1

    协议插件:auth_sha1_v2
    混淆插件:tls1.2_ticket_auth

    这样会更好吗

    hohoho9个月前 (06-05)回复
    • 不懂。。我一直用http

      91yun9个月前 (06-05)回复
      • http://www.abclite.cn/2226.html

        这篇文章写得挺详细的

        hohoho9个月前 (06-05)回复
      • 该站用的就是 协议插件:auth_sha1_v2+混淆插件:tls1.2_ticket_auth 站长可以参考下

        hohoho9个月前 (06-05)回复
        • 等我研究下

          91yun9个月前 (06-05)回复
          • 不用研究。。就是这两个好

            Oliver9个月前 (06-05)
    • 协议:verify_sha1
      混淆:tls1.2_ticket_auth
      作者说混淆能够抗重放攻击。协议就不需要了。

      Jack9个月前 (06-05)回复